NAT & PAT configuration on Cisco Packet tracer
Network Address Translation(NAT):
In other words NAT converts request from Private IP address to Public IP address and vice-verse. It helps in hiding the Private IP address of an organization by representing Public IP address as a source/destination.
Types of NAT
STATIC NAT:
ISPRouter(config)#interface serial 0/0
ISPRouter(config-if)#ip address 11.0.0.2 255.0.0.0
ISPRouter(config-if)#no shutdown
ISPRouter(config-if)#encapsulation ppp
ISPRouter(config-if)#clock rate 64000
ISPRouter(config-if)#exit
ISPRouter(config)#interface fast Ethernet 0/0
ISPRouter(config-if)#ip address 10.0.0.1 255.0.0.0
ISPRouter(config-if)#no shutdown
ISPRouter(config)#ip route 0.0.0.0 0.0.0.0 s0/0
ISPRouter(config)#ip nat inside source static 10.0.0.2 11.0.0.2
ISPRouter(config)#interface serial 0/0
ISPRouter(config-if)#ip nat outside
ISPRouter(config-if)#exit
ISPRouter(config)#internet fast Ethernet 0/0
ISPRouter(config-if)#ip nat inside
ISPRouter(config-if)#exit
Port Address Translation(PAT):
STEPS FOR CONFIGURING PAT IN CISCO ROUTER:
MYRouter(config)#internet serial 0/0
MYRouter(config-if)#ip ad 11.0.0.1 255.0.0.0
MYRouter(config-if)#no shutdown
MYRouter(config-if)#encapsulation ppp
MYRouter(config)#ip route 0.0.0.0 0.0.0.0 s0/0
MYRouter(config)#access-list 1 permit 192.168.1.0 0.0.0.255
MYRouter(config)#ip nat inside source list 1 int s0/0 overload
Video for the above configuration
http://youtu.be/igGz_zqdXZ0
- NAT is a process of changing one IP into another.
- NAT is used to save Public IP.
- It provides security.
In other words NAT converts request from Private IP address to Public IP address and vice-verse. It helps in hiding the Private IP address of an organization by representing Public IP address as a source/destination.
Types of NAT
- STATIC NAT(one-one mapping)
- DYNAMIC NAT(many-many mapping)
- PAT(many-one mapping)
STATIC NAT:
- One Private IP address is mapped to one Public IP address.
- Generally used for hosting public servers.
- Configured for inbound traffic.
ISPRouter(config)#interface serial 0/0
ISPRouter(config-if)#ip address 11.0.0.2 255.0.0.0
ISPRouter(config-if)#no shutdown
ISPRouter(config-if)#encapsulation ppp
ISPRouter(config-if)#clock rate 64000
ISPRouter(config-if)#exit
ISPRouter(config-if)#ip address 10.0.0.1 255.0.0.0
ISPRouter(config-if)#no shutdown
ISPRouter(config)#ip route 0.0.0.0 0.0.0.0 s0/0
ISPRouter(config)#ip nat inside source static 10.0.0.2 11.0.0.2
ISPRouter(config)#interface serial 0/0
ISPRouter(config-if)#ip nat outside
ISPRouter(config-if)#exit
ISPRouter(config)#internet fast Ethernet 0/0
ISPRouter(config-if)#ip nat inside
ISPRouter(config-if)#exit
Port Address Translation(PAT):
- Many Private IP address are mapped to one Public IP address.
- All users can access internet at the same time.
- Only configured for outbound traffic.
STEPS FOR CONFIGURING PAT IN CISCO ROUTER:
MYRouter(config)#internet serial 0/0
MYRouter(config-if)#ip ad 11.0.0.1 255.0.0.0
MYRouter(config-if)#no shutdown
MYRouter(config-if)#encapsulation ppp
MYRouter(config)#ip route 0.0.0.0 0.0.0.0 s0/0
MYRouter(config)#access-list 1 permit 192.168.1.0 0.0.0.255
MYRouter(config)#ip nat inside source list 1 int s0/0 overload
Video for the above configuration
http://youtu.be/igGz_zqdXZ0
ur student of zoom technologies i think ...
ReplyDeleteYes I am, did I miss something.
DeleteYes I am, did I miss something.
DeleteI am not getting sh ip nat translations
Deletehelp me
DeleteTry these ....
Deleteip nat translation max-entries
or
sh ip nat statistics
sorry for delay in response..
Vlinclugene Steven Hart https://ru.rocvideopromo.com/profile/Chrysler-Navtec-05064033ai-Inmotion-2-15-32-Iso-UPD/profile
ReplyDeleteseconschriste